installing mongoose on debian

Problem

I have encountered following error while trying install mongoose.

npm http GET https://registry.npmjs.org/mongoose
npm http 200 https://registry.npmjs.org/mongoose
npm http GET https://registry.npmjs.org/mongoose/-/mongoose-3.6.0rc0.tgz
npm http 200 https://registry.npmjs.org/mongoose/-/mongoose-3.6.0rc0.tgz
npm http GET https://registry.npmjs.org/hooks/0.2.1
npm http GET https://registry.npmjs.org/mongodb/1.2.11
npm http GET https://registry.npmjs.org/ms/0.1.0
npm http GET https://registry.npmjs.org/sliced/0.0.3
npm http GET https://registry.npmjs.org/muri/0.3.0
npm http GET https://registry.npmjs.org/mpromise/0.2.0
npm http GET https://registry.npmjs.org/mpath/0.1.1
npm http 200 https://registry.npmjs.org/ms/0.1.0
npm http GET https://registry.npmjs.org/ms/-/ms-0.1.0.tgz
npm http 200 https://registry.npmjs.org/sliced/0.0.3
npm http 200 https://registry.npmjs.org/hooks/0.2.1
npm http 200 https://registry.npmjs.org/muri/0.3.0
npm http GET https://registry.npmjs.org/sliced/-/sliced-0.0.3.tgz
npm http GET https://registry.npmjs.org/hooks/-/hooks-0.2.1.tgz
npm http GET https://registry.npmjs.org/muri/-/muri-0.3.0.tgz
npm http 200 https://registry.npmjs.org/ms/-/ms-0.1.0.tgz
npm http 200 https://registry.npmjs.org/mpromise/0.2.0
npm http GET https://registry.npmjs.org/mpromise/-/mpromise-0.2.0.tgz
npm http 200 https://registry.npmjs.org/mongodb/1.2.11
npm http 200 https://registry.npmjs.org/mpath/0.1.1
npm http GET https://registry.npmjs.org/mongodb/-/mongodb-1.2.11.tgz
npm http 200 https://registry.npmjs.org/hooks/-/hooks-0.2.1.tgz
npm http GET https://registry.npmjs.org/mpath/-/mpath-0.1.1.tgz
npm http 200 https://registry.npmjs.org/muri/-/muri-0.3.0.tgz
npm http 200 https://registry.npmjs.org/mpromise/-/mpromise-0.2.0.tgz
npm http 200 https://registry.npmjs.org/mongodb/-/mongodb-1.2.11.tgz
npm http 200 https://registry.npmjs.org/mpath/-/mpath-0.1.1.tgz
npm http 200 https://registry.npmjs.org/sliced/-/sliced-0.0.3.tgz
npm ERR! error installing mongoose@3.6.0rc0
npm ERR! error rolling back mongoose@3.6.0rc0 Error: UNKNOWN, unknown error '/home/vlad/node_modules/mongoose'

npm ERR! Unsupported
npm ERR! Not compatible with your version of node/npm: mongodb@1.2.11
npm ERR! Required: {"node":">=0.6.19"}
npm ERR! Actual:   {"npm":"1.1.0-3","node":"0.6.9"}
npm ERR! 
npm ERR! System Linux 3.2.0-4-486
npm ERR! command "node" "/usr/local/bin/npm" "install" "mongoose"
npm ERR! cwd /home/vlad
npm ERR! node -v v0.6.9
npm ERR! npm -v 1.1.0-3
npm ERR! code ENOTSUP
npm ERR! message Unsupported
npm ERR! errno {}
npm http GET https://registry.npmjs.org/sliced/0.0.4
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/vlad/npm-debug.log
npm not ok

Can someone suggest me how I can solve it?

Problem courtesy of: Vlad

Solution

The error tells you what the problem is:

npm ERR! Not compatible with your version of node/npm: mongodb@1.2.11
npm ERR! Required: {"node":">=0.6.19"}
npm ERR! Actual:   {"npm":"1.1.0-3","node":"0.6.9"}

You have a version 0.6.9 of node installed, but the dependency package mongodb requires a version greater or equal to 0.6.19. You can upgrade by doing:

sudo npm install n -g
Solution courtesy of: making3

Discussion

There is currently no discussion for this recipe.

This recipe can be found in it's original form on Stack Over Flow.